迷宫问题 POJ - 3984

题目

定义一个二维数组:

int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

代码

#include <iostream>
#include <cstring>
#include <stack>
using namespace std;
struct queue_point
{
	int x,y,steps,father;
}queue[30];
int map[6][6],head=0,tail=0,step=0;
bool visited[6][6];
void kuozhan(int x,int y)
{
	visited[x][y]=true;
	queue[tail].x=x;
	queue[tail].y=y;
	queue[tail].steps=step+1;
	queue[tail].father=head-1;
	tail++;
}
int main()
{
	memset(map,0,sizeof(map));
	memset(visited,0,sizeof(visited));
	for(int i=1;i<=5;i++)
		for(int j=1;j<=5;j++)
			cin>>map[i][j];
	queue[tail].x=1;
	queue[tail].y=1;
	queue[tail].steps=0;
	queue[tail].father=-1;
	visited[1][1]=true;
	tail++;
	while(head!=tail)
	{
		queue_point s=queue[head++];
		if(s.x==5&&s.y==5)
		{
			stack<queue_point> temp;
			temp.push(s);
			while(s.father!=-1)
			{
				s=queue[s.father];
				temp.push(s);
			}
			while(!temp.empty())
			{
				cout<<'('<<temp.top().x-1<<", "<<temp.top().y-1<<')'<<endl;
				temp.pop();
			}
			return 0;
		}
		if(s.x+1<=5&&!visited[s.x+1][s.y]&&map[s.x+1][s.y]==0) kuozhan(s.x+1,s.y);
		if(s.y+1<=5&&!visited[s.x][s.y+1]&&map[s.x][s.y+1]==0) kuozhan(s.x,s.y+1);
		if(s.x-1>=1&&!visited[s.x-1][s.y]&&map[s.x-1][s.y]==0) kuozhan(s.x-1,s.y);
		if(s.y-1>=1&&!visited[s.x][s.y-1]&&map[s.x][s.y-1]==0) kuozhan(s.x,s.y-1);
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

大风车滴呀滴溜溜地转

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值